
What is LanSchool?
LanSchool is a robust, classroom management program that our KS IT Department has purchased for 
our K-12 Kapälama campus.  It replaces Chicken of the VNC.  LanSchool helps:

1. Facilitate learning by allowing the teacher to show their screen and audio to students.

2. Remove distractions such as the Internet, applications, USB drives and printing.

3. Keep students on task through real-time thumbnail monitoring.

4. Get students’ attention by blanking out their screens.

5. Assist students through remote control and chat.

Getting Started:  Downloading LanSchool
To get started, you must download the LanSchool application from Self Service.

1. In your Applications folder, find Self Service and double-click to launch.  If you are 
not connected to the school’s network, you must connect via VPN before launching Self Service.

2.On the right side of the Self Service window under “Categories,” click on 
“Admin Apps.”

3. In the next window that appears, click INSTALL under LanSchool 
Kapalama Teacher.  

4.LanSchool will begin to install on your computer. The bar at the top of the 
window will display progress.  

5. When the download is completed, you should see this icon on the left of your 
Self Service window:

6.You may now quit Self Service.

Getting Started:  LanSchool Initial Setup
Complete the steps below to first time you launch LanSchool.  

1.To launch the LanSchool  application, open your Applications folder.  Locate the  LanSchool 
folder and double-click on Teacher.

2.You will need to enter the teacher password and click OK.

3.Next, go to Teacher > Preferences and click on the Network tab.
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Password:  pahu2125

 This is the password is for all teachers K-12 at Kapālama!  DO NOT compromise!  KEEP 
THIS PASSWORD CONFIDENTIAL!



4.Click on the radial button next to IP-Directed Broadcast.

5.In the Subnet 1 field, type 10.5.204.21

6.Click the radial button next to USE SINGLE CHANNEL. In the Channel Number field,  type 
your 4 digit number assigned to you 
by your ITS representative. 

7.Click on the Drive Limiting tab. 

8.Be sure to uncheck USB Drive.

9.Click OK.

Complete the steps below to create files to import your students into LanSchool.  You will use KS 
Connect and Microsoft Excel to create CSV files to import into LanSchool.  You will repeat steps 1- 10 
for each class that you teach.

1.Log into your KS Connect account to obtain the KS AD usernames for your 
students.

2.Click the Class Information link on the left of the window and select your 
class from the pulldown menu on the top left.

3.In the Class Information window under Class Downloads, click the 
LanSchool Class List link.
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4.In the browser window that appears, select all of the AD usernames for students in this class by 
pressing the Command + A keys simultaneously (or Edit > Select All).  

5.Then copy the AD usernames by pressing the Command + C keys (or Edit > Copy).

6.Launch Microsoft Excel and create a new Excel Workbook.

7.Be sure to that cell A1 is selected.  

8.Then paste the usernames into the Excel Workbook by pressing the Command + V keys 
simultaneously (or Edit > Paste).

9.The cells under the A column should be filled with 
your students’ KS AD usernames.

10.Save this as a CSV file.  To do this, press the 
Command + S keys simultaneously (or File > Save As), 
type a name denoting this teaching section/period/class, 
and save to a location you’ll remember. Under Format, 
be sure to select Comma Separated Value (CSV) then 
click SAVE.

11.Repeat Steps #1-10 for all of your teaching sections/periods.  Quit Microsoft Excel when finished.

Complete the steps below to import 
the Microsoft Excel CSV files into 
LanSchool.

1.In LanSchool, go to Administer > 
One to One > Manage Class Lists.  

2.Be sure that Login Name is 
selected in the next window.

3.Then click Import Student(s).

4.Navigate to the CSV file you 
created in the steps above and click 
Open.

5.The KS AD usernames you 
imported should be 
visible on the left of the window.

6.Click Save and name the file with 
a name that denotes this teaching 
section/class and click Save.  This 
will create a lsc file for this class.

CLASS MANAGEMENT SOFTWARE INTRODUCTION	
 	
 2013

PAGE 3 OF 10	
 	
 LANSCHOOL INTRODUCTION

Tip:  You might want to create one 
folder on your laptop called 
LanSchool and save all lsc files in this 
folder.  This will help you to locate 
these files quickly and easily when you 
want to manage a class.



7.Click Close when finished.

8.Repeat steps 2-7 for all other teaching sections/classes. 

9.Be sure to click Close when all CSV files are imported.

Using LanSchool
Launch your class in LanSchool

1.In LanSchool, click on the arrow to the right of the Class List icon in the toolbar and select Load 
Class List or Administer > One to One > Load Class List.

2.Navigate to the lsc file on your desktop saved in the previous steps and click Open.

3.You will see thumbnails of your students’ screens that are logged into the KS network in your 
window.  

4.If you are unable to see your students’ screen:

•First, ensure that the student is connected to the right network.  Go to the Airport icon               
on the student’s computer and verify they are on the KS_STUDENT_WPA2 network.

•You may also reboot your computer and launch LanSchool to reestablish connection.

Default LanSchool Toolbar

Features of the LanSchool toolbar will be briefly highlighted below.  Note that the toolbar is 
customizable and directions for adjusting the toolbar are included below.  If you would require further 
assistance or training, please contact your respective ITS/ITRT.

SHOW

• Show Full Screen:  Allows the teacher to show the teacher’s screen on the student’s screen 
and disables the keyboard and trackpad.  Note:  Students will be able to see any of the 
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Icon shows student’s 
application currently in use



teacher’s visible windows not including the LanSchool Teacher Console. Be sure to close any 
windows you do not want to share with students.  To show the full screen, click on the triangle 
next to  Show > Full Screen.  It will prompt you to confirm that you’d like to share your screen 
with students.  Click Continue.  When finished, click the LanSchool icon in your dock.  This will 
simultaneously stop screen sharing and will return you to the LanSchool application.  

• Show Windowed:  When enabled, this feature displays the teacher’s screen on the student’s 
screen in a resizable window and DOES NOT disable the student’s keyboard and trackpad.  To 
enable this feature, click on the triangle next to Show >  Windowed.  It will prompt you to 
confirm that you’d like to share your screen with students.  Click Continue.  When finished, click 
the LanSchool icon in your dock.  This will simultaneously stop screen sharing and will return 
you to the LanSchool application. 

SHOW STUDENT

This feature allows the teacher to show a student’s screen to all other students.  Select a 
student in the thumbnail view and click the “Show Student” button.  While the button is 
enabled, the student will have control of their machine and their screen will be shown to 
the rest of the students in this class.

VOTE, TESTING, RUN

•Not recommended for use.  You are encouraged to use Edmodo or 
BlackBoard for these functions.
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Show windowed:  Teacher’s shared 
screen with yellow and black border



CONTROL

During Remote Control, the keyboard and trackpad are disabled for students.  To 
enable, select a student in the thumbnail view.  Then click on the triangle next to 
Control > View or Control > Remote Control.  To stop this feature, click on the 
triangle next to Control > Stop Viewing or Remote Controlling. 

VIEW ALL

This will show all computer screens in the class as a small, medium, 
large, or extra large thumbnail.  As you move your cursor over a 
thumbnail image, the student’s login name and computer name appear.  
If you hover over a thumbnail for about a second, it will get larger.  You 
will see  the application the student is current using.  Note:  There is a 

slight display delay when viewing student screens in the thumbnail view.  

If you right click ( Control + click) on a thumbnail view, you will get a menu of 
options to control that student. 

SNAPSHOT

This will enable you to quickly take a snapshot of a student’s screen.  
Simply select the student in the thumbnail view. Then click the 
“Snapshot” icon from the toolbar.  The image will include the date, time, and student login 

and will save as a .jpg or .bmp file.

MESSAGE

• Send messages to all students.  The message will appear in the upper right-hand corner 
of  students’ screen.

• Chat:  Chat with a selected student. The chat window will appear in the middle of the student’s 
screen.
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Teacher Console Student screen



SPEAK

Note:  Audio feedback may occur if a student’s laptop is too close to the teacher’s laptop.  If 
this occurs, create a slight distance between the teacher and student laptops or adjust the 
volume on the laptops.

• Speak to class:  Allows the teacher to broadcast their audio to the students in the class.  Note:  
There is a slight delay. 

• Let student speak to class:  Allows the student you select to have their audio broadcasted to the 
rest of the students in the class.  In the thumbnail view, click on the student’s screen icon and 
select “Let student speak to class” feature.

• Talk with student:  By selecting a student and enabling 
this feature, the teacher’s microphone is turned on and 
broadcasts the audio to the student.

• Listen to student:   Turns on the microphone of the 
selected student and broadcasts the audio to the 
teacher’s console.

BLANK SCREEN

Note:  Using a kahakō in your message will prevent 
the blank screen from displaying on student 
computers; an ‘okina will function properly.

You can blank-out all student screens and disable all 
student keyboards and trackpads.  The message may be customized in the Preferences menu (Teacher > 
Preferences) or click on the arrow to the right of the Blank Screen icon and select “Configure Blank 
Screen Message.”  You can also rotate through any message you already have created by selecting 
another message from your list.   To undo the feature, click on the arrow to the right of the Blank Screen 
icon and select “Unblank Screen”.

LIMIT WEB, APPS, PRINT, AND DRIVES

These features are not recommended at this time.

MUTE

This allows you to mute the sound on student computers.  

CLEAR DESKTOP

This feature is not recommended at this time.  This feature closes students’ open 
applications and does not afford students ample time to save work.  This feature is not recommended.

SHOW VIDEO

This feature is not recommended at this time. 
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CO-BROWSE THE INTERNET

This feature limits students’ browsing on the Internet only to the site 
the teacher has in their primary tab.  If multiple tabs are opened by the 

teacher in Safari, the primary tab is the tab currently viewed by the teacher.   This feature is supported in 
Safari on Macs.  If a student deviates from the website in the teacher’s primary tab and attempts to visit 
another site, LanSchool will redirect the students back to the website in the primary tab after a few 
seconds.  To disable this feature, click on Co-Browse again.

Other Features:
CHOOSE RANDOM STUDENTS

• Make asking questions fun by having LanSchool randomly select a student. The student's will 
enjoy the sound and suspense to see if they get chosen.  Upon clicking Choose Random Student, 
a “Wheel of Fortune” sound will be audible and a “Jeopardy” sound will be heard when a 
students is selected by Lanschool.  This is what will appear on the selected students laptop. 

SEND/COLLECT FILE FOLDERS

• This feature is not operational at this time.  You are encouraged to use Turnitin, Blackboard, or 
Edmodo instead.  

DRAW ON SCREEN

•    When you are sharing your teacher screen with the class, you have the ability to write on whatever  
       application you have on your screen by left clicking and dragging a red marker.  Click at the top 
       tab to stop drawing on your screen.
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INTERNET HISTORY

• Shows a searchable list of 
websites visited by the selected 
student.  This list can also be 
saved as a text file (.txt).  On the 
Mac, Safari and Firefox are both 
supported.  

• To utilize this feature, click on a 
student’s screen in the thumbnail 
view.  Go to Monitor > View 
Student Internet History.

• To save the file, click Save.  Then 
name the file and select the 
desired file location.  

• Click Close when finished.

Customize the Toolbar

If you would like to customize the LanSchool toolbar to have quick access to the features you frequently 
use, follow the directions below.

In the LanSchool menu, go to View > Configure Toolbar.

• To add an icon to the toolbar, click on drag an icon from the window that appears and drag to 
your toolbar.

• To delete an icon from your toolbar, click and hold on the icon you’d like to remove and then 
release out of the toolbar.  
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• To reorder the icons, click on hold on the icon you’d like to relocate in your toolbar, then drag to 
the desired location in the toolbar.

• Click Done when finished.  

Closing LanSchool
Switch between your LanSchool classes.

1. In the toolbar in the Teacher Console (LanSchool window), click on the arrow to the right of the 
Class List icon.  In the pulldown menu, click Dismiss Current Class.

2. Then, return to the pulldown menu for the Class List icon.  Select Load Class list and navigate 
to the .lsc file that you saved for your class.  

Ending your LanSchool session.

1. In the toolbar in the Teacher Console (LanSchool window), click on the arrow to the right of the 
Class List icon.  In the pulldown menu, click Dismiss Current Class.

2. Then go to Teacher > Quit Teacher or Command + Q.
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