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LOGGING INTO KS CONNECT 
1.  Connect to  https://connect.ksbe.edu/ in your Web browser 
2.  Enter your KS username and KS password in the labeled boxes.  This is the same username and password you use to get 

into your KS e-mail. 
3.  Click the “Login” button.  

 
NAVIGATING KS CONNECT 

 
 
 

To get to your 
Advisory/Homeroom: 
Switch between Teacher 
and Advisory/Homeroom 
Teacher  here. 

 
 
Student/Class 
Loaded: Tells you 
which class or 
student’s information 
you are viewing. 

 
Features:  These will 
link to school-wide 
information.   The 
Daily Bulletin and 
Weekly Calendar are 
in “Bulletin”. 

 
 

Tasks: Use 
Tasks to get to 
the information 
in KS Connect 
including your 
classes and 
students. 

 
 
 
 
 

NOTES ABOUT THE NEW KS CONNECT 
What is new about the technology? 
The new version of KS Connect is built on the latest standards for Web applications (AJAX). KS Connect will not work in 
Older Web browsers or not work as well as intended in non-standards compliant Web browsers (i.e. Internet Explorer).  You 
should use Firefox on PC and Safari or Firefox on MAC.  If you don’t have Firefox on your PC, then use Internet Explorer. 
Why does the “Back” button not work? 
After logging into KS Connect, all navigation within the site must be done using the links provided in KS Connect.   You 
cannot use the back button to go back to the previous screen within KS Connect.   If you hit the “Back” button, it will take 
you to the previous site you visited before you came to KS Connect. 
Why does KS Connect look and behave differently in Internet Explorer (IE)?  Why do some things not work in IE? 
Internet Explorer is not a standards compliant Web browser.   We did our best (and will continue) to make the site behave as 
Intended in Internet Explorer (both versions 6 and 7).  If you want the full effect of the new KS Connect, we recommend 
downloading and installing a standards compliant Web browser.   The site is fully tested with the two most popular standards- 
compliant Web browsers: Firefox and Safari. 
Why does KS Connect take so long to load when I first login? 
After the first login, all subsequent logins should be faster because your browser will cache (keep a copy on your computer) 
the CSS stylesheets and javascript files.  The site will appear faster because it does not need to be downloaded from the 
server each time. 
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You will need the information below to setup your EGP Grade Book.  Every school has required terms 
that must appear in your grade book in order for KS Connect to work properly.   It is essential that you 
follow this table.   ALL YELLOW CELLS MUST BE ENTERED INTO YOUR GRADEBOOK. 

 
Grading Period Term Name Terms Course Is Offered EGP Term Report Card Term 
KS KAPÄLAMA  HIGH SCHOOL & KS HAWAI’I HIGH SCHOOL 
1st   Quarter Quarter 1 YR, S1, Q1 Q1 1ST QTR 
2nd   Quarter Quarter 2 YR, S1, Q2 Q2 2ND QTR 

 Semester 1 Final Exam YR, S1 S1E SEM EXAM 
 Semester 1 YR, S1 S1 1ST SEM 

3rd   Quarter Quarter 3 YR, S2, Q3 Q3 3RD QTR 
4th   Quarter Quarter 4 YR, S2, Q4 Q4 4TH QTR 

 Semester 2 Final Exam YR, S2 S2E SEM EXAM 
 Semester 2 YR, S2 S2 2ND SEM 

KS MAUI HIGH SCHOOL 
1st   Quarter Quarter 1 YR, S1, Q1 Q1 1ST QTR 
2nd   Quarter Quarter 2 YR, S1, Q2 Q2 2ND QTR 

 Semester 1 YR, S1 S1 1ST SEM 
3rd   Quarter Quarter 3 YR, S2, Q3 Q3 3RD QTR 
4th   Quarter Quarter 4 YR, S2, Q4 Q4 4TH QTR 

 Semester 2 YR, S2 S2 2ND SEM 
KS KAPÄLAMA  MIDDLE SCHOOL & KS MAUI MIDDLE SCHOOL 
1st   Quarter Quarter 1 YR, Q1 Q1 1ST QTR 
2nd   Quarter Quarter 2 YR, Q2 Q2 2ND QTR 
3rd   Quarter Quarter 3 YR, Q3 Q3 3RD QTR 
4th   Quarter Quarter 4 YR, Q4 Q4 4TH QTR 
KS HAWAI’I MIDDLE SCHOOL 
1st   Trimester Trimester 1 YR, T1 T1 1ST TRI 
2nd   Trimester Trimester 2 YR, T2 T2 2ND TRI 
3rd   Trimester Trimester 3 YR, T3 T3 3RD TRI 

 
The EGP terms replace  Term 1, Term 2, Term 3…in Easy Grade  Pro as shown below. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Note: You create other terms by adding a letter and a number after the term if you need additional terms (S1E, S2E). Don’t forget to name 
your class.  EGP only can accommodate 10 terms in one grade book.  If you need more terms, start a new grade book. Please make sure 
that all terms at least fit in one grading period.   Starting another grade book does mean that you will need to manually transfer the grades 
over at the end of the semester to compute the semester grade. 
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1. Login to KS Connect (http://connect.ksbe.edu/). 

 
2. Verify that your role is a teacher by looking at the 
current selection in the “Role” pop-up menu.   If it is not 
teacher, then select teacher in the menu. 

 
 

3. Click on “Information” in the “Class” section. 

 
 

4. Select your first class from the popup list. Click on 
[Download Class List] found at the bottom of the class you 
want to import into Easy Grade Pro. 

 

 
 
 
 

5. Your class list will load in a plain text format. 
Go to File > Save As. Save the file on your desktop. Give 
it a (unique) name and remember where you saved it. 
(Suggestion: Make the name with Course Name/Period. 
You should use .txt as the extension  instead  of .php) 
Click [Save]. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

REPEAT THE PROCEDURE  FOR ALL OF YOUR 
REMAINING CLASSES. 

 

 
 
 

6. Open  Easy Grade Pro. Click on [Create a New 
Grade book]. 

7. Click on [Add Classes]. 
 
 
 
 
 
 
 
 
 
 
8. Type in the term label names.   You must have all the  
terms listed in your school’s section  of “Terms for Easy  
Grade Pro (EGP) Gradebook”.  Don’t forget to name  
your class. 
 
Next, you type in your Custom Label. Use the label shown 
below.   You can find the Section ID in KS Connect  as 
shown in the screenshot  below. 
 

 
 
 
 
 
 
 
 
Repeat for all your classes by clicking on 
[Next Class>>]. 
 
Click [Done] when finished. 
 
9. Choose your first class in your first term from the 
“Choose a Class” pull-down  menu. 
 
10. Click on [View/Edit Class Options]. 
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11. Put in KS Grade Scale. (You can rename  or delete any 
other scales on the list.) 

 

 
 

If you use weighted  grades, now click on Category. 
In Category, click [Yes] on “Use Category Weights?”. List 
your category names and percentage weight for each. 

13. Select [“Easy Import of Students”] and click on [Next]. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
14. Select [Current Class]. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

Click [Done] when finished. 
 

12. A dialogue  box will appear  asking about students. 
Click [Import from Another File] found at the bottom  of 
the window. 

15. Select All Files from the pull down menu near the 
bottom.   Then, find your saved file from step 7. Click on 
[Open]. 
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16.  Now, type in Student Import in the field for Name of 
Format. 

 
Next, Complete  pull down fields in right column  to match 
the information  in the left column.   Use the table below to 
match the fields to the format of the file. 

 
Click [Next]. 

Click [OK] on “Import Results” window. 

 
 
Now click on [No]. 

 
 
18. Choose your next class in your Gradebook.  Click 
[Import from Another File] found at the bottom of the 
window. 

 
 
 
 
 
 
 

CLASS LIST FILE FORMAT 
 
 
 
 

19. Click on [Other Formats] and choose “Student 
Import”. Click “Next”. 

 
 
 

17.  Now, click on [Import Selected Records]. 20. Select [Current Class]. 
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21. Then, find your next class period  file saved in step 7. 
Click on [Open]. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

22.  Now, click on [Import Selected Records]. 

 
 

Click [OK] on “Import Results” window. 

 
 

Now click on [No]. 

 
 
 

REPEAT STEPS 18–22 for each class. 
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1. Make sure your EGP grade book is open and that you 
have made  the necessary updates  to assignments,  
scores, etc. 

a. In the updated version of EGP 4.1, there is an 
additional step needed to have the option to 
create your Basmati file.  You will only need to 
do this step one time. 

b. When your grade book is open, under File, you 
will initially not have the option to create your 
Basmati file. 

 
c. To fix this, at the top toolbar, while pressing 

the OPTION key, select File and click on 
Internet/Edline.  This option will remain there 
from now on.  Proceed to step 2. 

 
     2. In the menu bar, choose File > Internet/Edline. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

3. In the Action pop-up menu, choose Create Basmati file. 
 
 
 
 
 
 
 
 

 
4. In the For pop-up menu,  choose All Classes in [Term]. 

 
 
 
 
 

5. Choose the Options tab. 
 
 
 

 
 
6.  Set your options as pictured below: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
7. Click the [Create] button in the bottom-right corner of the 
dialogue. 

 
 
8. The Save Basmati File window will appear. 
Save the basmati.txt file to your desktop. 

 
 
 
 
 
 
 
 
File Name 

 
 
File Name 

 
 
 
 
 
 
 
 
 

Your grade book information will be saved in the 
Basmati.txt file on your Desktop. 
 
9. Login to KS Connect (http://connect.ksbe.edu/). 
 
10. Verify that your role is a teacher by looking at the 
current selection in the pop-up menu.   If it is not teacher, 
then select teacher in the menu. 
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11. Click on “Current Grades” in the “Class” section. 
 

 
 
 
 
 
12. Click on the [Browse] or [Choose File] button. 
 
 
 
 
 
The Choose File window will appear.  In the dialogue, locate 
and click on Basmati.txt on the desktop. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Click on the Open button. 
 
 
Click on the Submit Grades button. 

 
 
 
 

 
 
 
13.  A table listing the Student ID numbers and corresponding 
grades will appear. 

 
 
 
 
 
 
 
 
 
 
 
 
 

 
Verify that the contents of the basmati.txt file have uploaded 
correctly by looking at the student ID numbers and making 
sure there is a letter grade next to each one. 
 
You have finished uploading your grades and may either logout 
or continue to use KS Connect
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ISSUING PROGRESS REPORTS ADDING AN ENTRY TO THE CONVERSATION LOG 
 

1. Login to KS Connect  (https://connect.ksbe.edu/). 
 

2. Verify that your role is a teacher by looking at the 
current selection  in the “Role” pop-up  menu.   If it is not 
teacher, then select teacher in the menu. 

 
 

3. Click on “Information” in the “Class” section. 

 
 

4. Click the Progress Report button  in the same row as the 
student. 

 
 
 
 
 
 
 
 

5. The Progress Report form appears.  The student’s 
current grade will appear automatically. (You can adjust 
the grade if necessary.) Complete  the rest of the form as 
appropriate. 

 
 
 
 
 
 
 
 
 
 
 

NOTE: The “Comments”  text box IS NOT the same as the 
“Conversation Log” in the issued progress report! 
Comment text box is for you to explain in more detail the 
reason for this Progress Report. The Conversation Log will 
be used by those who read and have a need  to 
communicate to you or others about the Progress Report. 

 
6. Click the [Submit] button (not the [Select] button). 

1. Login to KS Connect  (https://connect.ksbe.edu/). 
 
2. Verify that your role is a teacher by looking at the 
current selection  in the pop-up menu.   If it is not teacher, 
then select teacher in the menu. 

 
 
3. Click on “Progress Reports” in the “Class” section. 

 
 
4. A list of all of the progress reports you have issued for 
the class will appear. Click “View” to view the progress 
report that requires your attention. 

 
 
5. Click [Add] next to the title “Conversation Log”. 

 
 
6. Type what you want to record in the Conversation Log. 

 
 
7. Click the [Add] button. 
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After receiving an e-mail requesting that a Grade  Check be 
completed… 
 
1. Login to KS Connect  (https://connect.ksbe.edu/). 
 
2. Verify that your role is a teacher by looking at the 
current selection  in the “Role” pop-up menu.   If it is not 
teacher, then select teacher in the menu. 

 
 
3. Click on “Grade Checks” in the “Class” section. 

 
 
4. A list of all of the grades checks that require your timely 
response  will appear  here. Click the “answer” link. 
Note: Grade checks are sorted in ascending  order with 
most recent requested  grade check on the bottom. 
 
 
 
 
 
5. The student’s current  grade will automatically appear  in 
the Grade  Check. (You can adjust the grade if necessary.) 
Complete  the rest of the form as appropriate. 
 

 
6. Click the [Submit] button. 

 
You can adjust the information you entered until the due date at 11:59 PM. 
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If you have trouble creating a Basmati file or uploading grades to KS Connect, please double check some of these 
common errors: 
 

Error Solution 
No option visible to create a 
Basmati file in EGP 4.1 

a. In the updated version of EGP 4.1, there is an additional step 
needed to have the option to create your Basmati file.  You will 
only need to do this step one time. 

b. When your grade book is open, under File, you will initially not 
have the option to create your Basmati file. 

 
c. To fix this, at the top toolbar, while pressing the OPTION key, 

select File and click on Internet/Edline.  This option will remain 
there from now on. 

 
Trouble creating a Basmati file In the Basmati option tab, check teacher information. Teacher ID needs to 

be a zero (0). 
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KS Connect Upload Error Check Term Labels that apply to your course and make sure the Term 

Labels are written as Q1 not Quarter 1 or S1E not Semester 1 Exam, etc. 
Check Section ID’s from KS Connect to make sure they match. 
 

 
 
 
 
 
 
*Cut and paste section ID from KS Connect 
 

Uploading a new Basmati file does 
not change grades on KS Connect 

Delete old Basmati file from your computer and create a new one.  Upload 
to KS Connect again. 
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